Archive

Posts Tagged ‘Validaciones’

Evitar introducir datos repetidos con validación de datos

September 26, 2011 21 comments

Excel cuenta con una herramienta muy funcional, la cual es, Validación de datos, que entre otras cosas nos permite validar la entrada de datos:

  1. Rangos de números.
  2. Fechas.
  3. Horas.
  4. Longitud de texto.
  5. Ingreso de listas.
  6. Funciones personalizadas.

La que nos atañe en este post es la de Función personalizadad. Lo que deseamos es que Excel no nos permita introducir datos repetidos, y que en su lugar nos envíe un aviso personalizado.

Cómo funciona ?

En este caso tenemos nuestro rango que será “A1:A10”. Elegimos todo el rango y nos vamos al menú/pestaña Datos > Validación. En el combo Permitir elegimos Personalizada e introducimos la siguiente fórmula:

=CONTAR.SI($A$1:$A$10,A1)=1

Posteriormente, dentro del mismo formulario elegimos la pestaña Mensaje de entrada y personalizamos nuestro mensaje.

image

La validación nos permite limitar los datos de ingreso

Al momento de ingresar algún dato repetido, Excel nos arrojará un mensaje previamente personalizado donde le indiquemos al usuario acerca de los datos repetidos.

image

Excel nos permite personalizar nuestros mensajes para hacer la labor más dinámica

Listas de validación dependientes en Excel

April 26, 2011 2 comments

El presente ejemplo nos permite asignar dos listas de validación, con la salvedad de que, dependiendo de lo que se elija en una, la otra muestra los datos en base a esa lista.

Se realiza con validaciones de lista, pero en lugar de poner el nombre o el rango de la lista, se ingresa una fórmula personalizada que permite realizar lo que deseamos.

El ejemplo tiene dos campos de validación: el primero nos arroja una lista de estados, y el segundo campo nos enlista los municipio del estado seleccionado. Así como muestra la imagen:

image

Se cuenta con una segunda hoja donde están definidas las listas que requerimos, y cada parte de las listas tienen un nombre asignado, para que nuestras fórmulas funcionen.

:: Descargar archivo de ejemplo