Archive

Posts Tagged ‘Trucos’

Sumar la misma celda de varias hojas en Excel

January 29, 2012 Leave a comment

Les dejo un truco sencillo que nos permite sumar una misma celda, pero de todos las hojas abiertas, no importando cuántas sean.

La forma más conocidas, pero laboriosa es separar por comas cada celda de cada hoja hasta llegar a la última, pero eso puede provocar que nos falte una celda y ver una fórmula muy larga, como la siguiente:

=SUMA(A1,Hoja2!A1,Hoja3!A1,Hoja4!A1,Hoja5!A1,Hoja6!A1,Hoja7!A1,Hoja8!A1,Hoja9!A1,Hoja10!A1,Hoja11!A1,Hoja12!A1)

Supongamos que queremos sumar todas las cantidades que se encuentran en la celda A1 de todas nuestras hojas, pero lo queremos hacer de manera rápida. Para eso la siguiente fórmula nos ayudará con el propósito, incluso la podemos copiar hacia cualquier dirección si queremos hacer la suma de otras celdas.

=SUMA(Hoja1:Hoja12!A1)

Macro para convertir los números con formato de texto a número en Excel

December 27, 2010 14 comments

Twittear este post Compartir en Facebook

El siguiente código hace la tarea de convertir los números reconocidos como texto, en el formato correcto. Aplica principalmente cuando importamos a Excel datos de alguna página Web o desde alguna aplicación externa, con una consulta. En mi experiencia, estos debería ser solucionado con la opción de formatear celda como número, pero muchas veces no sucede, así que debemos editar cada celda con F2, pero resulta una tarea imposible cuando tenemos muchos datos.

Funciona para formatos correctos de número, hora, fecha, etc.

Aquí el código de la macro:

Sub ConvertirTextoANumero()
Dim celda As Range
Application.StatusBar = "Convirtiendo celdas seleccionadas a formato de número..."
For Each celda In Selection
    'Se evalua cada celda del rango y se hace la conversión
    celda.Value = CStr(celda)
Next celda
Application.StatusBar = False
End Sub
Categories: vba Tags: , ,

Mi teclado escribe números y no letras

November 17, 2010 Leave a comment

Twittear este post Compartir en Facebook

A raíz de un problema técnico que le sucedió a una persona cercana a mi, que su Lap, en lugar de escribir letras, escribía números, me di a la tarea de investigar la solución.

Dependiendo del teclado que se tenga, hay dos maneras de solucionarlo:

  1. Presionar la tecla Fn + Shift + Bloq Num
  2. Presionar la tecla Fn + Shift + Num Lk
Categories: Trucos Tags: , ,