Archive

Posts Tagged ‘INDICE’

Uso de K.ESIMO.MAYOR, COINCIDIR, INDICE en una misma fórmula de Excel

October 22, 2010 7 comments

Compartir:

Twittear este post Compartir en Facebook

En varias ocasiones nos topamos con fórmulas grandes con funciones anidadas y que a simple vista son de difícil lectura. El siguiente ejemplo nos deja más claro cómo realizar este tipo de fórmulas paso a paso. El ejemplo nos muestra cómo obtener de una lista de nombres con sus respectivas ventas, quién es el 1ro, 2do y 3er lugar dependiendo de las ventas.

Primeramente tenemos nuestra base de datos con sólo dos columnas: la columna Nombre y la columna Ventas.

1.- El primer paso es obtener cuál es el número mayor de ventas. Esto lo obtenemos con la función K.ESIMO.MAYOR. Cabe destacar que esta función nos da el número k.esimo de una lista, de mayor a menor:

[B10]=K.ESIMO.MAYOR(B2:B8,1)

2.- Ahora que obtenemos el valor del número k, que en esta ocasión fue el número mayor, el 1, nos disponemos a obtener la posición de dicho número en la fila, con la función COINCIDIR:

[B11]=COINCIDIR(B10,B2:B8,0)

3.- Cuando sabemos la posición en la que está el número mayor, el 1ro, nos disponemos a obtener el nombre de la persona que tuvo ese número de ventas, con la función INDICE. Dicha función nos da el valor correspondiente de acuerdo a la intersección de fila columa que definimos en los parámetros.

[B12]=INDICE(A2:B8,B11,1)

4.- Hasta este momento ya obtuvimos el valor de la persona que tuvo más ventas, pero utilizando 3 funciones, una en cada celda. Ahora necesitamos unirlas todas. Si nos damos cuenta, en la celda [B11] hacemos referencia a la celda [B10], entonces la fórmula que está en [B10] la copiamos y la pegamos íntegramente donde dice ‘B10’ en la fórmula de [B11], y así hacemos lo mismo en la celda [B12]. Dándonos como resultado la siguiente fórmula:

=INDICE(A2:B8,COINCIDIR(K.ESIMO.MAYOR(B2:B8,1),B2:B8,0),1)

Resumen:

Con K.ESIMO.MAYOR obtuvimos el número mayor de ventas que es 120, después con COINCIDIR sacamos la posición de ese valor en la tabla, que fue la posición 3. La intersección que nos dan las dos funciones pasadas son fila 3 y la columna donde está el valor que queremos es la columna 1, por lo tanto, el nombre que nos arroja es Toño.

Imagen del ejemplo:

image

:: Descarga el ejemplo